We identified that the access issues impacting users in Canada were caused by an overload of database connections. Our engineering team promptly scaled up resources to reduce the load and successfully restore normal performance. We are continuing to monitor the system closely to ensure ongoing stability.
Posted May 16, 2025 - 15:26 MDT
Update
We are continuing to investigate this issue.
Posted May 16, 2025 - 14:55 MDT
Investigating
We are currently investigating an issue where the Build/Platform is not loading or displaying an error message. This issue appears to be affecting customers located in Canada only. Our team is actively working to identify the root cause and restore full functionality as quickly as possible.
We apologize for the inconvenience and we will be provide updates as we learn more.