Our team identified the root cause and have deployed a fix to restore access. We apologize for the inconvenience this caused and if you have any further questions or issues please feel free to submit a support ticket.
Posted Jun 16, 2025 - 08:18 MDT
Investigating
Users are receiving an error message when initiating forms through links. Initiated forms are available in the user’s Drafts list. Our engineers are investigating the issue and will keep you posted as we have more information.
Posted Jun 16, 2025 - 08:03 MDT
This incident affected: United States (Oregon) and Canada (Montreal).