This issue is now resolved and environments in the US region should be back up again.
The incident was caused by an unexpected database coordination issue that prevented the database cluster from operating normally, resulting in a temporary service disruption. The issue was identified and the cluster was restored to its expected operating state.
We'll be doing a full retro and take the necessary steps to avoid this type of disruption in the future. Our apologies for the disruption this caused your users.
Posted Jul 07, 2026 - 20:04 MDT
Identified
We've identified the issue and putting in a fix to resolve the issue - once fully restored and stable we'll give another notification.
Posted Jul 07, 2026 - 19:59 MDT
Investigating
We're actively investigating reports of environments in the US region not loading - we apologize for the inconvenience and we'll let you know more as soon as possible.