Platform/Build intermittent issues

Incident Report for Kuali

Postmortem

Our server provider (Mongo) identified a bug that was causing inefficient queries and led to the instance getting into a bad state. We have since upgraded to the latest version of Mongo to address the bug. We have also scaled up the servers to enhance system performance. We apologize for the inconvenience this caused and if you have any further questions or issues please feel free to submit a support ticket.

Posted Apr 22, 2025 - 14:12 MDT

Resolved

The issue affecting Kuali Build and Kuali Next-Gen products is now resolved. Our monitoring is complete and we have scaled up our systems to ensure improved performance across environments. We will keep you posted as we know more about the root cause and we apologize for the inconvenience this caused . If you have any further questions or issues please feel free to submit a support ticket.
Posted Apr 14, 2025 - 18:01 MDT

Monitoring

Our engineers have fixed the intermittent issues loading Kuali Build and Kuali Next-Gen products. We’re continuing to monitor and investigate the root cause and we’ll keep you posted as we know more.
Posted Apr 14, 2025 - 17:13 MDT

Investigating

We are receiving reports of intermittent issues loading Kuali Build and Kuali Next-Gen products. Our engineers are currently investigating and we will keep you posted on our progress. We apologize for the inconvenience this may be causing.
Posted Apr 14, 2025 - 16:57 MDT
This incident affected: United States (Oregon) and Canada (Montreal).