Our engineers identified a configuration issue that was limiting system capacity below the expected level. The configuration has been corrected, and system performance has improved.
We will continue to monitor the environment and are taking additional steps to help prevent this issue from recurring.
Posted Jul 13, 2026 - 10:24 MDT
Update
We apologize for the disruption. Our engineers have increased system capacity, and performance has improved. The system is now loading as expected. We are continuing to monitor the environment and investigate the underlying cause, and we will provide additional updates as more information becomes available.
Posted Jul 13, 2026 - 10:06 MDT
Update
Our engineers are still actively working to restore normal service. We will provide another update as soon as there is additional progress to share.
Posted Jul 13, 2026 - 09:38 MDT
Update
Our engineers are continuing their investigation and working toward a resolution. We will provide another update as soon as additional information is available.
Posted Jul 13, 2026 - 09:01 MDT
Update
We are continuing to investigate this issue. We will share another update as more information becomes available.
Posted Jul 13, 2026 - 08:35 MDT
Investigating
We are investigating a service disruption affecting Platform and Build customers. Users may experience issues loading pages, accessing applications, or completing actions within the system. Our team is actively working to restore normal service. We will provide additional updates as more information becomes available.
Posted Jul 13, 2026 - 08:07 MDT
This incident affected: United States (Oregon) and Canada (Montreal).