Build/Platform not loading

Incident Report for Kuali

Postmortem

The issue was caused by increased load on the database, which temporarily impacted application availability. We’re making performance improvements to help prevent future incidents.

Posted Jul 29, 2025 - 07:42 MDT

Resolved

Users experienced issues loading the application. The problem was due to a database-related issue and was resolved after services recovered.
Posted Jul 28, 2025 - 17:30 MDT