Platform/Build loading issues

Incident Report for Kuali

Postmortem

This issue was caused by a temporary disruption during recent updates that impacted connectivity between services. Service was restored shortly after the issue was identified. We are taking steps to improve deployment processes and reduce the risk of similar disruptions in the future.

Posted Apr 02, 2026 - 06:43 MDT

Resolved

Users experienced a brief period where the Platform/Build was not loading due to a temporary disruption in service connectivity.
Posted Apr 01, 2026 - 11:00 MDT